Jump to content

Help needed - Firefox 4 reports WebGL not enabled..


majithia23

Recommended Posts

hello friends ....

well i been trying out the new FF today ,

when noticed this strange thing ..

upon using some Demo apps , from here --- Mozilla presents - Web-O-Wonder .

WebGL and HTML 5 at Mozilla Labs - Mozilla App Directory

WebGL games

( specifically the Barfight game , Runfield game , Planet Buster game . )

it reports WebGL is not enabled in the browser or update your video driver .

i tried the same links ( a WebGL game link and a Demo link ) in Chrome ,

but it works fine there .

no messages ...

its clear and the links and the game work good ...

so this shows there is no problem with the video driver .. ( and they are uptodate too ... )

so why is FF reporting WebGL not available ...? :think:

any settings required , openly or under the hood ?

thanks ...

Link to comment
Share on other sites

  • Replies 6
  • Views 846
  • Created
  • Last Reply
  • Administrator

What does it say when you type webgl in about:config?

Link to comment
Share on other sites

yeah i tried that too ...

have a look ---

ahnfd.jpg

now if i enable this -- " webgl.force-enabled;false " to " true " ,

then it seems to work fine ...

there are no warnings or messages ....

now i wonder , i manually ' forced ' the browser to use WebGL , and it did ....

shouldnt it be doing it by default ... ?

how do you have it enabled in your browser ?

did you run any app/game to see the result ...

:think:

Link to comment
Share on other sites

  • Administrator

I see. I have no idea why. Nor know how to enable webgl via settings.

But yeah I played the Runfield game yesterday and today just fine. :)

Link to comment
Share on other sites

D ,

you too have the same settings for WebGL under about:config on your system too , like mine ?

and with these default settings , all was ok on your system .

no messages , or errors ?

Link to comment
Share on other sites

  • Administrator

Yeah same here in about:config. But had no errors like that. It seems that many others are having the same problem ATM.

Link to comment
Share on other sites

well its just not on my side ,

there are many other FF more too , reporting WebGL not enabled .

its because , Firefox is blocking certain ATI , nVidia , Intel drivers , due to bugs ..

check this link to see the blocklist and also find instructions to by pass or over ride the block and enable the WebGL again in FF 4 .

Blocked Graphic Drivers

thanks to DKT27 for the link ... :)

+1

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...