Jump to content

Packet Errors (Wireless Router)


shought

Recommended Posts

I was experiencing some issues with my Wireless connection and I managed to fix them today, I can imagine that some of you might some day run into the same issue, so I thought I'd post about it ;)

When I was using my wireless I would frequently lose the connection (like once every minute, for 10-30 seconds) and I found out that 'the cause of this' were large numbers of packet errors. At first I thought my neighbors might be to blame, they all be using wireless as well and obviously I have more right to wireless than they do :rolleyes: :P But it turned out I was already using the optimal channel. So obviously, as any right minded person would do, I brought it to my tech-support guy - uhh... I read the manual - hmm... I started randomly clicking settings and afterwards downloading large files to enforce packet errors if they would appear (there's only so little settings, didn't take long for me to brute-force the solution :P).

So as it turns out my router has b/g/n support, which also allows channel bonding (in order to increase speed). I believe it also makes use of two antennas, but let's not get into specifics. Anyhow this channel bonding (which was represented in my settings as either 20 Hz (off) or 20/40 Hz (on)) seems to have caused the issues, because after I turned it off there were no more packet errors.

I'm not sure whether this is due to flawed firmware of the router, a flaw in my laptop's network card or errors caused by interference from my neighbors (although I think this is highly unlikely, I'd say, from my observations, that this is some kind of technical issue), but I'm sure turning channel bonding of fixed this issue and I'm sure my neighbors are also glad I did so, because using two out of 11 channels (and only 1, 6 and 11 should actually be used) is just rude ;)

Link to comment
Share on other sites

  • Replies 7
  • Views 3.4k
  • Created
  • Last Reply

being Samaritan is sometimes as pain as being greedy. :sneaky: personaly- only do piggy back, never share nothing :duh: I know....

Link to comment
Share on other sites

Using 40 MHz bandwidth actually uses 9 channels so that explains your packet errors. You can only get it if you choose channel 1 as the lower control channel, channel 11 as the upper control channel, or channel 6 upper or lower.

Else just use 20Mhz bandwidth.

Link to comment
Share on other sites

Well, it doesn't 'use' 9 channels (as in actually use them to send data), but obviously the channels overlap so you will 'block' 9 channels when using this mode. ;)

I can't even choose channels, I can just choose one, the other one will be automatically determined (will always be 4 channels away from the first channel).

Link to comment
Share on other sites

Nice info.

Question though, were you having these packet errors ever since you used this router or just recently? Because, if you just had these errors recently on the same router, I was wondering why you're not having problems before without having to change a setting. :unsure:

Link to comment
Share on other sites

Aha! I knew it, that someone was going to ask this :P

I didn't want to mention this, but the actual 'culprit' was, in fact, one of my neighbors (who moved here recently). They also had a router with channel bonding enabled and this caused the issues to 'surface'. (So it did work before they moved here.)

But 'culprit' isn't correct, obviously, because I was poisoning their networks as well :rolleyes: (The setting was enabled by default...)

Link to comment
Share on other sites

Channel is just an easy way to say the centre frequency you are using, instead of saying 2.437GHz centre frequency on my wireless you can say I'm using channel 6, so whether you call it use or block the result is the same you need 9 channels to get the 42MHz bandwidth and yes it uses all 40MHz to transmit data if you have a device capable of communicating at 40MHz bandwidth, the extra 2 are just because the amplitude rolloff isn't mathematically capable of attenuating to zero instantaneously so while the signal goes to zero it slopes and ends up blocking 1MHz on each side, those are actually blocked and not used for any data. Your router automatically picks the Auxiliary channel after you set the control channel (always 4 channels away) so the easiest thing is to just pick the centre channel 6.

Now using 40MHz is useless unless you have actual devices capable of using the bandwidth else it's creating problems for you unnecessary. Better to stick with 20MHz channel bandwidth, but even with this when you select the channel you want it will use or block 4 channels to get the full 22MHz it requires to operate. What's the purpose of me telling you that? Well it just means that if your neighbour uses channel 1 then you should use channel 4, always 3 channels away to avoid interference and overlap. In that case with him using channel 1, he will block 2 unnamed channels below channel 1 and then 2 channels above (channels 2 and 3). Well you can use anything from 4 go up, unless you have other neighbours doing their thing well try to stay 3 channels away from everyone and if he is using 40MHz bandwidth on channel 1 then your best bet is to use channel 11 or 12 or 13 on the high side.

Personally I am a mean bastard and I am blocking channels 1 to 8 for no reason, my laptop can work fine with narrow bandwidth but what kind of neighbour would I be if I didn't annoy those bastards around me? It's not like they consider me when they annoy me with their stupid music. :sneaky:

I think I am winning though since you mentioned this I went to check my packet info: Received (RX) 47921 OK, 32 errors; Transmitted (TX) 85659 OK, 28 errors; over 2 days.

What router do you have anyway?

Link to comment
Share on other sites

Yeah, I know about the channels ;) Just wanted to point out that 'using' 9 channels doesn't mean 'using 9 channels' (as in sending data through 9 different channels). 'Using 9 channels' means 'utilizing 2' (I know you know this, but I just wanted to explain what I meant).

I also kind of figured the 40 MHz mode was useless, I can now reach (actual) speeds over wireless of over 5 MB/s (65 Mbps 'reported'), which is fast enough for me :)

We have a ZyXEL P-2601HN-F1.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...