Jump to content

DVD-Rom + Writer disappeared....


InfernoSB

Recommended Posts

I have a DVD-Rom and a DVD-Writer which disappeared from my My Computer thing. I dunno what happend or what do I check or do to bring it back. Usually WinXP autodetects this but it doesn't now. Before it did and I could see my drives along with my virtual drives. Just recently there not showing no more and I can only see my virtual drives and not my real dvd-rom drive. Can anyone suggest anything to maybe possible getting these to reveal or detect them again. :)

*I also checked under device manager and its not shown in there as well :/

Link to comment
Share on other sites


  • Replies 2
  • Views 1.9k
  • Created
  • Last Reply

You said you checked the device manager and no joy there?

Only thing I can think off at this time which should definately do it is to shut down PC. Leave it 10 mins. Open up the case, and please ensure you're grounded so you don't destroy anything componants by static electricity. Wearing a anti-static wirst band, or touching a radiator that's been grounded should do it. Then unplug the molex connectors to ensure it's not connected.

Start up PC, no need to close case again. Let it all load up. Shut down again, and leave another 10 and ground yourself once more.

Plug in all your connectors again for these 2 drives, and close case.

Start up PC. It should recognise them again. I have a feeling you may have told your PC not to inform you anymore, so this should fix that.

Link to comment
Share on other sites


You said you checked the device manager and no joy there?

Only thing I can think off at this time which should definately do it is to shut down PC. Leave it 10 mins. Open up the case, and please ensure you're grounded so you don't destroy anything componants by static electricity. Wearing a anti-static wirst band, or touching a radiator that's been grounded should do it. Then unplug the molex connectors to ensure it's not connected.

Start up PC, no need to close case again. Let it all load up. Shut down again, and leave another 10 and ground yourself once more.

Plug in all your connectors again for these 2 drives, and close case.

Start up PC. It should recognise them again. I have a feeling you may have told your PC not to inform you anymore, so this should fix that.

Works like a charm again ^^ thanks for the suggestion Samurai. Seems that after installing System Mechanic and doing all those performance/scan tuning, it needed a few reboots before everything was in order hehe.

Link to comment
Share on other sites


Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...