Jump to content

Make PayPal default in PlayStore - Solved (Somewhat)


eurotrash
 Share


Recommended Posts

Hi everyone,

I cannot set paypal as my default payment method, playstore insists on using my debit card, but I want to use my paypal. According to several user forums, Google removed the option a while back. Any ideas?

Edited by eurotrash
Link to comment
Share on other sites


  • Administrator

While again it may not help you there, but atleast here, Google never introduced it as an option. The reason is, Google wants to push it's own payment service and that it is why it did not want to allow other payment services like the one you have mentioned on the Play Store, atleast that's what I found here.

Link to comment
Share on other sites


1 hour ago, DKT27 said:

While again it may not help you there, but atleast here, Google never introduced it as an option. The reason is, Google wants to push it's own payment service and that it is why it did not want to allow other payment services like the one you have mentioned on the Play Store, atleast that's what I found here.

 

I can add paypal, but when I want to pay for an app, it wants to use my debit card, not my paypal. sigh

Link to comment
Share on other sites


In playstore I can use both paypal and google payments normally  :o

 

What an error message  that you got when you try to pay with your debit card ?

Link to comment
Share on other sites


3 hours ago, Akaneharuka said:

In playstore I can use both paypal and google payments normally  :o

 

What an error message  that you got when you try to pay with your debit card ?

 

No error. If I look in the playstore under payment options, I see my debit card and my paypal. If I try to buy an app, it shows me that I am paying with the debit card, and there is no option to select paypal.

Edited by eurotrash
  • Sad 1
Link to comment
Share on other sites


4 hours ago, eurotrash said:

 

No error. If I look in the playstore under payment options, I see my debit card and my paypal. If I try to buy an app, it shows me that I am paying with the debit card, and there is no option to select paypal.

 

try to add you paypal account at

 

http://payments . google . com

Link to comment
Share on other sites


I haven't exactly solved this, but for people with the same problem, here is a work-around I discovered. 

 

1. Open GooglePlay

2. Find an app you want to buy

3. Press Buy, now you will see a dialogue box asking for a confirmation if you are sure you want to buy

4. Under the title of the game/app you will see Mastercard XXX/Visa XXX/ or something similar, press on the credit/debit card

5. Now it will give you a dialogue box asking you which payment method you want to use

 

Note: Still can't figure out how to set the default, doesn't seem to be an option, but at least you can use the payment method you prefer. Hope this helps!:D

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...