Jump to content

FireFox Memory Leak is a Feature!


nsane

Recommended Posts

SenseOfHumor writes "The Firefox memory leak is not a bug. It's a feature! The 'feature' is how the pages are cached in a tabbed environment." From the article: "To improve performance when navigating (studies show that 39% of all page navigations are renavigations to pages visited less than 10 pages ago, usually using the back button), Firefox 1.5 implements a Back-Forward cache that retains the rendered document for the last five session history entries for each tab. This is a lot of data. If you have a lot of tabs, Firefox's memory usage can climb dramatically. It's a trade-off. What you get out of it is faster performance as you navigate the web."

Source: http://rss.slashdot.org/Slashdot/slashdot?m=3702

to disable the feature...

1. type about:config in you address bar

2. scroll down to browser.sessionhistory.max_total_viewers

3. set its value to 0 (zero)

...now enjoy a less memory intensive FF :lol:

WARNING: unless you know exactly what you're doing, do not mess with anything else on this screen!

Link to comment
Share on other sites

  • Replies 3
  • Views 3.5k
  • Created
  • Last Reply
SacredCultivator

OH wow.. yeah I noticed that I still had this problem, thanks for the notice.

Link to comment
Share on other sites

SenseOfHumor writes "The Firefox memory leak is not a bug. It's a feature! The 'feature' is how the pages are cached in a tabbed environment." From the article: "To improve performance when navigating (studies show that 39% of all page navigations are renavigations to pages visited less than 10 pages ago, usually using the back button), Firefox 1.5 implements a Back-Forward cache that retains the rendered document for the last five session history entries for each tab. This is a lot of data. If you have a lot of tabs, Firefox's memory usage can climb dramatically. It's a trade-off. What you get out of it is faster performance as you navigate the web."

Source: http://rss.slashdot.org/Slashdot/slashdot?m=3702

to disable the feature...

1. type about:config in you address bar

2. scroll down to browser.sessionhistory.max_total_viewers

3. set its value to 0 (zero)

...now enjoy a less memory intensive FF ;)

WARNING: unless you know exactly what you're doing, do not mess with anything else on this screen!

Hey nsane,

I was really excited to try out the solution you posted. Since I upgraded to FF 1.5, I've had the memory problems. Memory problems as in Firefox using up to 300mb of memory. I went to try the fix you posted but found to my utter disappointed that the value was ALREADY set to zero...I used to visit the Firefox forum for help (which was of no use) and they must have already posted that fix. Which I tried, and DOESN'T WORK.

As I am typing this, I am looking at my task manager and am finding Firefox to be using 104 mb of memory.

Thanks for the post anyway, dude. But if you find anything else make sure to keep us up to date, mkay?

In the mean time, I'm downgrading to 1.0.6 just to be on the safe side. We have 1.0.6 on the household PC and it uses satisfactory amounts of memory. My college's comps have 1.0.4 installed and it runs perfectly.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...