Jump to content

How to Force S3 Sleep State in Windows.


LeetPirate

Recommended Posts

LeetPirate

This guide can also be found elsewhere on the internet but for the sake of broadening awareness I want to share it here too.

Basically there are 2 sleep states in Windows, S1 and S3. Most of the time all you have to do is set your BIOS sleep mode to "S3 only" and it should always use S3 sleep state.

However you could also configure Windows to force S3 sleep state to ensure that your system saves maximum power.

While I don't have exact figures because each PC is different, I can tell you that S1 sleep state only saves a couple of watts of power but S3 on the other hand only uses a couple watts of power and thus saves quite alot more. For more information about power savings you could visit this website.

This is only tested in Windows XP and *Vista but should also work in Windows 2000.

1.) First you need to download the following application called dumppo.exe (Mirror).

2.) Open a command prompt and change to the directory you placed the dumppo.exe file. (If you are not familiar with dos commands just put it in the "c:" drive or the "Windows" folder.

3.) Type the following command and press enter, "dumppo admin". The following information should be displayed.

>dumppo admin
Admin policy overrides
Min sleep state......: S1
Max sleep state......: S4 - hibernate
Min video timeout....: 0
Max video timeout....: -1
Min spindown timeout.: 0
Max spindown timeout.: -1

4.) Notice the minimum sleep state is S1 by default. Type the following command and press enter, "dumppo admin minsleep=S3". You should now get the following information on the screen.

>dumppo admin minsleep=S3
Admin policy overrides
Min sleep state......: S3
Max sleep state......: S4 - hibernate
Min video timeout....: 0
Max video timeout....: -1
Min spindown timeout.: 0
Max spindown timeout.: -1

There you have it, start listening to Al Gore by saving more energy :angry:.

*Note about Vista. Word on the internet has it that Vista defaults to S3 sleep state even though S1 is set as the minimum sleep state. I don't have a wattmeter to really test that so I just go ahead and change it anyway. I also suggest you disable hibernate in Vista and just use hybrid sleep for desktops and regular sleep for laptops.

To disable hibernation in Vista do the following: At the command prompt type "powercfg -H off" and press enter. Click here for more details.

Link to comment
Share on other sites


  • 4 weeks later...
  • Replies 1
  • Views 8.9k
  • Created
  • Last Reply

Thanks for the amazing guide, dunno why I havn't replied before but I saved the link and now I fixed a computer which wouldn't enter S3 only S1. After the fix I got a error about the the mouse, the Logitech driver wouldn't let the computer enter S3 so before the fix it only entered S1. After that I tried updating the driver but that didn't work so I uninstalled and now it's fine!

Thanks again!

Link to comment
Share on other sites


Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...