Jump to content

How to disable the BITS service in windows 8


rudrax

Recommended Posts

There is a service called Background Intelligent Transfer Service (BITS) in windows 8 which continuously uses your bandwidth whenever you connect to the internet. This is real pain in a$$ when you try to disable it. After disabling and restarting the computer it recovers again and you connect to the internet - this forever hungry fella comes again and starts eating your bandwidth again.

So, I wanna know if there exist a permanent way to disable it so that it can't recover itself after system restart.

Link to comment
Share on other sites


  • Replies 18
  • Views 3.3k
  • Created
  • Last Reply

Top Posters In This Topic

  • rudrax

    6

  • AlienForce1

    2

  • spudboy

    2

  • NeowinMOD™

    2

Top Posters In This Topic

task manager ,Services,on the left bottom corner "open service" , navigate to "Background Intelligent Transfer Service "
right click, properties
5wREFMX.png
then save & you're Done

Edited by nanoman
Link to comment
Share on other sites


NeowinMOD™

Transfer Service (BITS) has 2 Service dependency, I think if you remove those dependencies it won't run again, how to check dependecies:

First you have to open Regedit.

Then navigate here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\

Then find BITS key like this:

TPdxKPW.png

Then click BITS key and check the right hand side window and find key named DependOnService

Then double click DependOnService key and delete all the text there and hit OK.

Then disable BITS Service again and restart your computer.

PS: Remember to take a backup of that registry key before making any changes.

You can also open GPEdit and navigate here:

Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler

EwX4U6R.png

Then check right hand side window and find key named Limit reservable bandwith, double click it and select Enabled and then lower the score to 0, then hit Apply and OK, restart your computer.

This GPEdit trick makes Windows Update much slower, so it's not recommended to use.

Edited by NeowinMOD™
Link to comment
Share on other sites


AlienForce1

Why should you bother to look in registry ?

nanoman pointed you right .

Start (I asume you have StartIsBack+) -> All Programs -> Administrative Tools -> Services -> go to BITS , double click on it -> Disable -> ok B)

Link to comment
Share on other sites


NeowinMOD™

Why should you bother to look in registry ?

nanoman pointed you right .

Start (I asume you have StartIsBack+) -> All Programs -> Administrative Tools -> Services -> go to BITS , double click on it -> Disable -> ok B)

Quote from rudrax:

After disabling and restarting the computer it recovers again.

That's why I mentioned Registry option, to check if there's another Service which launhes BITS Service.

Link to comment
Share on other sites


AlienForce1

I disabled from `Services` BITS and Windows Update and they never recovered by themselves . It works on XP , Vista , 7 , 8 , 8.1.

(I re-enable them only on Tuesday-Patch day)

Link to comment
Share on other sites


I don't know why it would be running every time you connect to the internet. Since reading this post I have been monitering it's use and even when downloading files from here (or anywhere else) it doesn't even start. Even manually starting Windows Update didn't make it start. Is there really a need to disable it? Seems like just another one of those "speed up your internet" or "speed up windows" myths.

Link to comment
Share on other sites


@rudax if this is related to a post of a short while ago, you still having something in your box phoning home to a server in Kuala Lumpur mate... :(

IMHO remove the culprit & all should be OK.. :)

I manage many machines / OS's over a variety of networks...Correctly configured / bug free systems should not have a problem with standard HIPS settings.

Link to comment
Share on other sites


task manager ,Services,on the left bottom corner "open service" , navigate to "Background Intelligent Transfer Service "

right click, properties

then save & you're Done

http://www.nsaneforums.com/topic/210662-how-to-disable-the-bits-service-in-windows-8/?do=findComment&comment=756404

Transfer Service (BITS) has 2 Service dependency, I think if you remove those dependencies it won't run again, how to check dependecies:

First you have to open Regedit.

Then navigate here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\

Then find BITS key like this:

Then click BITS key and check the right hand side window and find key named DependOnService

Then double click DependOnService key and delete all the text there and hit OK.

Then disable BITS Service again and restart your computer.

PS: Remember to take a backup of that registry key before making any changes.

You can also open GPEdit and navigate here:

Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler

Then check right hand side window and find key named Limit reservable bandwith, double click it and select Enabled and then lower the score to 0, then hit Apply and OK, restart your computer.

This GPEdit trick makes Windows Update much slower, so it's not recommended to use

Thank you for the effort. I did a trick and till now the BITS isn't starting anymore. I will observe if my trick works the will go to mess with the registry.

I disabled from `Services` BITS and Windows Update and they never recovered by themselves . It works on XP , Vista , 7 , 8 , 8.1.

(I re-enable them only on Tuesday-Patch day)

Seems, you are the lucky guy :)

I don't know why it would be running every time you connect to the internet. Since reading this post I have been monitering it's use and even when downloading files from here (or anywhere else) it doesn't even start. Even manually starting Windows Update didn't make it start. Is there really a need to disable it? Seems like just another one of those "speed up your internet" or "speed up windows" myths.

I'm not planning to speed up things currently.

Link to comment
Share on other sites


I don't know why it would be running every time you connect to the internet. Since reading this post I have been monitering it's use and even when downloading files from here (or anywhere else) it doesn't even start. Even manually starting Windows Update didn't make it start. Is there really a need to disable it? Seems like just another one of those "speed up your internet" or "speed up windows" myths.

I'm not planning to speed up things currently.

That was just an anology. There isn't any reason why it should be constantly, or semi-constantly running. I'm on Win 8.1 and have a hard time getting it to start if I TRY to make it start.

Link to comment
Share on other sites


As mentioned in my previous comment... the cause of the problem lies elsewhere

Have you ever observed a mobile GPRS proxy?

Link to comment
Share on other sites


SnakeMasteR

rudrax and the infested Microsoft dinosaur, bad combination. Google any infection or problem, rudrax already had it. :lol:

I'm better off now. :tehe:

Link to comment
Share on other sites


rudrax and the infested Microsoft dinosaur, bad combination. Google any infection or problem, rudrax already had it. :lol:

I'm better off now. :tehe:

:spank:

Link to comment
Share on other sites


stylemessiah

Madness, disabling BITS as already mentioned isnmt the answer. the answer is to get rid of the malware you have which is piggybacking. BITS is used for Windows Updates amongst other things, so disabling it will only make your system less secure and open to more malware

But maybe thats what youre going for, an increase in malware?

If youre not, find the true cause, as has already been mentioned.

This is at least the 3rd malware related post ive seen by the OP, so maybe n0_risk! is right:

rudrax and the infested Microsoft dinosaur, bad combination. Google any infection or problem, rudrax already had it

Edited by stylemessiah
Link to comment
Share on other sites


Transfer Service (BITS) has 2 Service dependency, I think if you remove those dependencies it won't run again, how to check dependecies:

First you have to open Regedit.

Then navigate here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\

Then find BITS key like this:

TPdxKPW.png

Then click BITS key and check the right hand side window and find key named DependOnService

Then double click DependOnService key and delete all the text there and hit OK.

Then disable BITS Service again and restart your computer.

PS: Remember to take a backup of that registry key before making any changes.

You can also open GPEdit and navigate here:

Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler

EwX4U6R.png

Then check right hand side window and find key named Limit reservable bandwith, double click it and select Enabled and then lower the score to 0, then hit Apply and OK, restart your computer.

This GPEdit trick makes Windows Update much slower, so it's not recommended to use.

This is always a last resort for me as hacking the registry if your not experienced with using the registry you can damage your system (no need to go in the registry to delete anything related to services you are GOING to crash your system for this case. Thank you for providing it this can work for someone so thank you. Going into services right click on bits service you can easily fix the problem from there the second tab gots contingency options for if the service fails it automatically launches itself if it gets shut off twice if not three times you can take care of that contingency your set microsoft put that in case malware processes try to shut it off.

As for the limit reservable bandwidth thats for the overall system and doesnt directly affect windows update. Yes enable it and put the value at zero then you take windows restriction off of usable bandwidth. In gpedit administrative templates network and bits there is a setting called limit the maximum network bandwidth for bits file transfers enable then double click and put your maximum download speed in KBps and then check use all available unused bandwidth click on apply then click on ok this speeds up bits and windows updates when downloading in the background. If you want to get rid of bits do as I suggested earlier eliminate the auto restarts for bits in the second tab..

Edited by Holmes
Link to comment
Share on other sites


@Holmes, I also used the second tab and set all those 3 options to "Take no action", yet the BITS starts automatically when you restart your system and connect to the internet.

Then I found that there is a fail log file for the service which reset at 1 day time by default. I set that to 9999 day. Now, as I'm expecting, the BITS service will start again in some 9999 days later - till then have peace.

Link to comment
Share on other sites


Im happy you figured it out keep us posted on what happens..

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...