Jump to content

[Solved] Windows 8: Unable to associate default application with file type


Zapdude
 Share

Recommended Posts

Hi,

I've got this weird problem. I downloaded media player classic and tried to associate it with mkv or other video files through settings default applications but even if i click apply the associated application won't change. I still stays as windows media player. Any ideas?

Thanks guys

Link to comment
Share on other sites

  • Replies 7
  • Views 1k
  • Created
  • Last Reply

Top Posters In This Topic

  • DKT27

    1

  • rudrax

    1

  • Zapdude

    3

  • Roger D

    1

Popular Days

Top Posters In This Topic

I had faced the same problem while I was on windows 7. Probably, you will need to associate file types during the installation of MPC. After installation, doesn't work with files types association easily.

Link to comment
Share on other sites

ya.. rudrax is right..you will have to associate file types during installation. or you can also try by going to the setting of MPC and then associate the file with the player if you have missed the association of files during installation.. :lol: :lol:

I have faced the same problem with png file when associating with Icofx. but by going to the setting of Icofx, I successfully associated the file with Icofx.

:D :D

Link to comment
Share on other sites

1. Install MPC-HC / MPC-BE(seems better for me)

2. After finish, open view > options

3. go to menu player > formats

4. click modify

5. check file type(s) that you want to associate, then click apply

6. click set default programs, check once again file type(s) that you want to associate, ... done..

if some file type than still unassociate, just do manual association with right click on the video then go to properties. change it manually :)

hope it could help you :)

Link to comment
Share on other sites

Hey guys, thanks for the fast replies! (nsaners rock.. ahem do you ever sleep? ;) ) rack thank you for letting me know about MPC-BE. everything is ok now.

I'm still wondering though, why did this happen.. bug?

Link to comment
Share on other sites

Thank you very much for your reply. If you read the OP i was trying to change them through "default programs" in control panel there shouldn't be any need to run MPC at all..

Link to comment
Share on other sites

  • Administrator

I think that setting is probably removed from WMP now, but it can be that WMP might be trying to re-associate files to it whenever it found that the files weren't.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...