Jump to content

AMD (ATI) Catalyst Drivers 12.6


Bizarre™

Recommended Posts

AMD's award-winning ATI Catalyst graphics and HD video configuration software delivers unprecedented control of performance and visual quality with ATI Radeon graphics processors. Certified by Microsoft Windows Hardware Quality Labs (WHQL), ATI Catalyst drivers for Windows Seven, Vista. XP operating systems deliver stable performance and push the limits of innovation with advanced user-oriented features.

Thanks to thylacine for the update.

Download

Link to comment
Share on other sites


  • Replies 29
  • Views 3.7k
  • Created
  • Last Reply
SacredCultivator

FOr those that did install it.. does it read out as 12.6 in the Software section of Catalyst?

Cause mine reads out 12.3 ><

Posted Image

So I think from what i said in the previous thread:

"When updating frontpage, I think best to put a caution/warning that the support for I believe 4800HD and under are gone now. =/"

Cause I'm using a HD 4860 and I think 12.4 may be the LAST supported driver for it, since it's now considered a LEGACY card.

Adding on from Guru3d

Link to comment
Share on other sites


@SacredCultivator:

Maybe it's a bug. Try reporting it to AMD so they can either issue a hotfix or correct it in the next build.

Link to comment
Share on other sites


SacredCultivator

Don't think it's a bug, think just improper removal if anything.

Because when reporting, the HD 4800 and below aren't listed as options.

But I'll do my best to report.

Link to comment
Share on other sites


SacredCultivator
Yups in my Report, I noted about how during the BETA testing of it, HD 4800 was removed already, so questioned about changing the Release Notes.
Link to comment
Share on other sites


FOr those that did install it.. does it read out as 12.6 in the Software section of Catalyst?

Cause mine reads out 12.3 ><

Posted Image

Link to comment
Share on other sites


brain_death

For those that did install it.. does it read out as 12.6 in the Software section of Catalyst?

Cause mine reads out 12.3 >

Don't think it's a bug, think just improper removal if anything.

This *is* because your 12.3 drivers were not removed properly beforehand. Mine read 12.4 (the previous version) on Linux until I uninstalled that version entirely and rebooted in-between. It has happened before too. Now showing 12.6 quite happily...

:D

Link to comment
Share on other sites


hi my dear friends

also for me here after i installed new version still shows me 12.4

bty i must download ati mobility coz my toshiba is satallite c650d

after i read comments here

one friend said that i must remove previous version then restart between then setup new version on clean

so i will try todownload again from ati russian site coz this site provides ati mobility drivers also

here is the link for who wants

http://forum.radeon....php?f=5&t=43294

12-6_mobility_vista_win7_32_dd_ccc

12-6_mobility_vista_win7_64_dd_ccc

wait me in another reply after unistall old one and setup new one

p.s i used before to make setup up on the old and all time shows me the new version

don't know what is wrong in this time

see u

Link to comment
Share on other sites


sorry my friends after all waht i did still shows me 12.4 no problem all is ok 12.4 is ok

Link to comment
Share on other sites


Just want to add that I installed 12.6 on top of 12.5 by over-writing (without uninstalling 12.5) ;)

Link to comment
Share on other sites


This and future drivers is only for HD7000, 6000 and 5000 series cards.

Link to comment
Share on other sites


SacredCultivator

Yeah for those that say 12.6 shows up, your card is above HD4800 I assume. I'm using a HD4800 series card.

So it's their Release Notes that need fixing. As 12.4 is latest driver for me.

Link to comment
Share on other sites


some notes:

The 2000, 3000 and 4000 Series will see an updated driver mid July - Catalyst 12.6 and 12.7 do not support 2000,3000, 4000 Series

Link to comment
Share on other sites


Yeah for those that say 12.6 shows up, your card is above HD4800 I assume. I'm using a HD4800 series card.

True, I'm on 5400. ;)
Link to comment
Share on other sites


brain_death

Yeah for those that say 12.6 shows up, your card is above HD4800 I assume. I'm using a HD4800 series card.

So it's their Release Notes that need fixing. As 12.4 is latest driver for me.

Still doesn't account for it showing v.12.3 though. Or did you get that fixed?

HD 6310 integrated graphics here btw, on a seriously budget notebook.

:s

Link to comment
Share on other sites


  • Administrator

some notes:

The 2000, 3000 and 4000 Series will see an updated driver mid July - Catalyst 12.6 and 12.7 do not support 2000,3000, 4000 Series

Damn. :(

Please make sure you keep us updated for it. :) As the update might be different than the normal one.

@SacredCultivator: It's a bug. 100% sure. Few days ago, I got my replacement card 4870. After installing 12.4, I found that it was reporting 11.12 installed! This was after many tries (uninstall, reinstall).

Then I searched and found that others are reporting the same issue (some having 6xxx card but reporting 12.3 instead of 12.4). Someone contacted AMD and asked about it, AMD guy replied saying that this will be fixed in the next update. Liars. :angry:

Link to comment
Share on other sites


Yeah, mine too. When I installed 12.4 it says 11.9 in the information. :wtf: I installed it over with 12.6 today and now it says 12.6. :)

Link to comment
Share on other sites


  • Administrator

Yeah, mine too. When I installed 12.4 it says 11.9 in the information. :wtf: I installed it over with 12.6 today and now it says 12.6. :)

Good to know.

Card? :)

I wonder why 4xxx cards are still in the list if the drivers are not for them.

Link to comment
Share on other sites


Thank you for the update.

Hope this version 12.6 will be more stable than the 12.4 and 12.3 versions...

Link to comment
Share on other sites


  • Administrator

@SacredCultivator & others: 3xxx and 4xxx cards have been silently removed from the 12.6 releasenotes' compatibility list yesterday. Confirming thylacine's quote and our doubts.

Link to comment
Share on other sites


Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...