Jump to content

firefox3.0rc2


mijai

Recommended Posts

Firefox is the award winning next generation browser from Mozilla. Firefox empowers you to browse faster, more safely, and more efficiently than with any other browser. Make the switch today - Firefox imports your Favorites, settings and other information, so you have nothing to lose. Stop annoying popup ads in their tracks with Firefox's built in popup blocker. View more than one web page in a single window with this time saving feature. Open links in the background so that they're ready for viewing when you're ready to read them. Built with your security in mind, Firefox keeps your computer safe from malicious spyware by not loading harmful ActiveX controls. A comprehensive set of privacy tools keep your online activity your business.

Download page

I see that this version is still under work but it will finally hit the surface on the 5th June

Link to comment
Share on other sites

  • Replies 10
  • Views 3.6k
  • Created
  • Last Reply

is anyone else having probs with flash player installing on firefox? (plugin)

with rc1? does it work with rc2?

Link to comment
Share on other sites

Flash player works fine here with rc1.

I haven't downloaded rc2 because I am waiting for the Dutch version.

Link to comment
Share on other sites

Flash player works fine here with rc1.

I haven't downloaded rc2 because I am waiting for the Dutch version.

Wierd, it keeps saying plugin installed, but keeps asking for it when I view a page that needs flash :unsure:

Edit

hmm

C:\WINDOWS\Downloaded Program Files

Download.DLL / was damaged some how :blink: (when trying to remove it/said it couldn't but its gone)

Edit

ok removing what ever that entry was, then reinstalling flash has worked! messy!!!

Link to comment
Share on other sites

herbert7890

u need to download the new flash player beta 10.xxxx for it to work on rc1. dont use the version 9.xxxx

Link to comment
Share on other sites

I thought they'd have finalised it by now. They said this month... last month!

Link to comment
Share on other sites

u need to download the new flash player beta 10.xxxx for it to work on rc1. dont use the version 9.xxxx

well the 9.0 seems to be working fine ;p

but ty for the info

Link to comment
Share on other sites

  • Administrator

This is still just a nightly build, not the finished RC2 :unsure:

Link to comment
Share on other sites

This is still just a nightly build, not the finished RC2 :unsure:
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...