Jump to content

All app updates submitted to Google Play are now required to target Android 10 and above


steven36
 Share

Recommended Posts

Google has once again shifted its target API level requirement for all apps submitted to Google Play. Since August 3, 2020, all new apps submitted to Google Play were required to target at least Android 10. Starting today, all updates to existing apps must target Android 10 (API level 29) or higher. The search giant made similar changes at the end of last year and has been requiring Android app developers to target newer API levels since 2017.

 

867t8e1.png

 

Since its stable release in September of 2019, Android 10’s distribution has grown steadily, with the operating system running on 100 million devices just 5 months post-launch. As of April of 2020, Android 10 was running on 8.2% of all Google-certified devices, though that percentage has likely gone up significantly in the last few months because Google has requirements on the OS version that new devices can launch with.

 

6vMjxWq.jpg

Source: Google

 

When you take a look at the many new APIs available in Android 10, you start to realize how important the release is. Some of the notable APIs include support for foldable devices, support for 5G, support for Dark Theme, and improved privacy features.

 

Most developers by now have likely adapted their apps to target Android 10 or higher, but any developer that hasn’t must now comply with Google’s rules or risk abandoning their software, which ultimately leaves consumers in a lurch.

 

By requiring app developers to target last year’s release of Android, Google is hoping to encourage the adoption of new APIs, thus providing users with an improved experience. Earlier versions of Android are still more prevalent than more recent releases, but with initiatives like Project Treble, Google is slowly closing the fragmentation gap and making it easier for OEMs to update their devices.

 

It will eventually be the same story next year when Google will require that developers target Android 11 (API level 30), which is the most recent release.

 

Source

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...