Jump to content

CyberLink PowerDVD Ultra v20.0.1519.62


flash13
 Share

Recommended Posts

Hint: you have to clean up all traces of any previous version and of the retail installed version (if you tried it) before installing the kit from the original post.

 

Edited by Dahaka
Link to comment
Share on other sites

Had to completely remove the PDVD19 , before installing the PDVD20 .

Program works very good , its an allround media-player ( movies , you-tubes, vimeos, music , CD/DVD/BlueRay ,etc. )

This 20-version is muuch bigger in bytes , compared with 19-version ( 535MB , 20-version is about 822MB !)

I could use some old lang-files from previous PDVD , and set the program in Dutch ( nl-NL) ...............awsome  :dance:

Link to comment
Share on other sites

2 minutes ago, Pete 12 said:

Had to completely remove the PDVD19 , before installing the PDVD20 .

Program works very good , its an allround media-player ( movies , you-tubes, vimeos, music , CD/DVD/BlueRay ,etc. )

This 20-version is muuch bigger in bytes , compared with 19-version ( 535MB , 20-version is about 822MB !)

I could use some old lang-files from previous PDVD , and set the program in Dutch ( nl-NL) ...............awsome  :dance:

When you installed it ,do you find BD3D icon ?

Link to comment
Share on other sites

I had the two versions 19 and 20 already installed without problems.

I reinstalled the above posted version 20 , it did uninstall the old version20 but didn't interfere with the version 19.

 

powerdvd.JPG.5fdfcd620e7fba0afce8ba50788d07c4.JPG

Edited by tonyblair
Link to comment
Share on other sites

One PDVD20 is sufficient for me .........why two versions ?  :coolwink:

" When you installed it ,do you find BD3D icon ? ".................not on my rig , not installed any BlueRay , not using it.

However , it does appear if you have BlueRay installed ( drivers, hardware ) .

btw , this is the only option which is missing , all the others are present !

Link to comment
Share on other sites

22 minutes ago, xuzhong said:

When you installed it ,do you find BD3D icon ?

 

answer from the ReadMe.txt :

Note: To have Blu-ray 3D module logo/feature enabled you might need to install the required drivers and need to have the required equipment to take advantage of this feature. Without required components installed, this feature won't be available.

14 minutes ago, Pete 12 said:

One PDVD20 is sufficient for me .........why two versions ?  :coolwink:

" When you installed it ,do you find BD3D icon ? ".................not on my rig , not installed any BlueRay , not using it.

However , it does appear if you have BlueRay installed ( drivers, hardware ) .

btw , this is the only option which is missing , all the others are present !

I was testing my own patching for DVD20 after reversing. And be able to listen to the divine Enya voice in the same time on the 19 working version.

  • Like 2
  • Haha 1
Link to comment
Share on other sites

52 minutes ago, sledge101 said:

hmmm. Anybody tested playing a movie iso file? 

I test it few minutes ago with a blue ray film "The Pirates from Columbia and Sony pictures animation" No problem here

Edited by tonyblair
Link to comment
Share on other sites

39 minutes ago, tonyblair said:

I test it few minutes ago with a blue ray film "The Pirates from Columbia and Sony pictures animation" No problem here

but i have a problem with the movies cover .. it did not  appear 

Link to comment
Share on other sites

Does anyone know roughly when the VL edition becomes available. it was a couple of months last time before this edition appeared.

Link to comment
Share on other sites

On 4/17/2020 at 2:15 AM, Danker1990 said:

Does anyone know roughly when the VL edition becomes available. it was a couple of months last time before this edition appeared.

CyberLink PowerDVD Ultra v20.0.1519.62  is the latest version on CyberLink-site also.........

Edited by KXR75
Case site removed
Link to comment
Share on other sites

1 hour ago, Danker1990 said:

Does anyone know roughly when the VL edition becomes available. it was a couple of months last time before this edition appeared.

The pre-activated version posted in this thread above, is activated with a Volume key.

Edited by tonyblair
Link to comment
Share on other sites

37 minutes ago, xuzhong said:

@sledge101

Any fix it ?

1.png.c5e9b32b98bc1c49ec6ae00086397a9e.png

i read in ru-board you can replace an older version file of this aboutWindow.kc  , but this is purely cosmetic as cl detects your hardware. mine i lack one 3d bluray

Link to comment
Share on other sites

5 hours ago, tonyblair said:

The pre-activated version posted in this thread above, is activated with a Volume key.

All I see above is some pre-activated version, not a direct link vl version.

Edited by I Am Negan
Link to comment
Share on other sites

1 hour ago, sledge101 said:

i read in ru-board you can replace an older version file of this aboutWindow.kc  , but this is purely cosmetic as cl detects your hardware. mine i lack one 3d bluray

I change one file ,and have this icon and more , but loss two new functions in Left side of main interface .

2.png.7713907ed1943efe6ff404ad2334455d.png

Edited by xuzhong
Link to comment
Share on other sites

4 hours ago, xuzhong said:

I change one file ,and have this icon and more , but loss two new functions in Left side of main interface .

2.png.7713907ed1943efe6ff404ad2334455d.png

yes it seems so, i dont have any 3d blu ray so i missed one reported, its fine with me as my hardware does not support 3d bluray. my movie iso file i can play but too selective others icant play..   but in v19 , all iso play and encoding decoding supports are a ok. i have 2 versions  in a test envirnomen,t.  it seems they need to pass thru the activation for all codecs to be all activated and support..

 

hmmm  let me push it further...

Link to comment
Share on other sites

On 4/17/2020 at 8:18 AM, sledge101 said:

yes it seems so, i dont have any 3d blu ray so i missed one reported, its fine with me as my hardware does not support 3d bluray. my movie iso file i can play but too selective others icant play..   but in v19 , all iso play and encoding decoding supports are a ok. i have 2 versions  in a test envirnomen,t.  it seems they need to pass thru the activation for all codecs to be all activated and support..

 

hmmm  let me push it further...

Could you please specify what are the types of the  "movie iso you can't play" with version 20 and plays in version 19.

Link to comment
Share on other sites

6 hours ago, tonyblair said:

Could you please specify what are the types of the  "movie iso you can't play" with version 20 and plays in version 19.

2k/4k uhd bluray iso ...in v20  but strange no issues in v19. usual install....

 

with further test i got it fixed. iso i can play now  2k/4k/8k bluray uhd.   looks good. mp4, hevc, its fine now. i think i know whats causing it especially in final build of v20 ultra.

 

i did some few offset patching and sims t be ok in powerdvd.sim , installed the iso driver, restarted pc so cyberlink can setup devices. and iso file loads beautifully and fast in v20.

 

thanks tony.

 

 

 

 

Edited by sledge101
  • Like 3
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...